Resolved
This issue has now been resolved, and queues have been processing normally.
We apologise for any inconvenience this may have caused you.
Monitoring
Queue Workers are processing through the backlog, and volumes are approaching normal levels. We'll confirm once fully resolved
Monitoring
Engineering have implemented a change and we are now monitoring progress.
Identified
Engineering have identified a possible cause and we can see the speed of processing gradually start to increase.
Investigating
We're investigating delays in processing contacts imported from third-party platforms. Engineers are looking into it now, and we'll provide an update shortly.